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What is Pronto for Windows?

Pronto for Windows allows you to use a computer to:

Start and stop recordings on a connected logger.

Create a configuration for a logger and then load it into the logc
Transfer data from a logger or data pack and save it on the comput
Organize your data in one or more projects.

Plot graphs from raw or processed data.

Analyze the data in a graph by zooming in to focus on small portic
Analyze the harmonics of snapshots recorded using the Harmonics Ar
Create and print a document containing listed or graphed data and
Use Object Linking and Embedding (OLE) to import objects such as ¢
word-processed text into a document.

Pronto for Windows organizes your data in the following way:

Projects
%rojects are used as directories were used in Pronto for DOS, to ¢
When data is played back, it is saved in a project, which stores t
streams. By using projects, Pronto for Windows allows you to orge
Pronto for DOS. When you open a project, the information stored i
special window called the ‘project browser’.

Data streams
Pronto for Windows stores data differently from Pronto for DOS. 1
stored as a ‘session’, i.e. data recorded on all channels over one
equivalent of the .DTA files used in Pronto for DOS. At the same
streams. A data stream consists of all data recorded on one chanr
more sessions.

Views
When you want to create a document by plotting data on a graph anc
view. A view is a window that shows a page of a document. You ce
and pictures, and to arrange these items in the view before printi
for DOS .PLT files.

Reports
To get precise details of recorded data, you can create a report.
recorded on a logger, as a tabular listing. A report shows exact!
graph but in a numerical form. Graphs instantly give the impress:
data and can be zoomed to get precise values; reports show the ex:
data, allowing a very quick and accurate examination.



The Pronto Screen Layout

Pronto for Windows uses the standard Windows layout. At the top of
title bar is a menu bar, from which you may choose options which wil
toolbar below the menu bar contains buttons that provide quick acces

The Title Bar

The Menu Bar

The Toolbar

The Scroll Bar

Tha Status Bar

The control menu box

Tha maximize hudton

The restore button

Arranging windows and cons
Moving and resizing windows




Logger menu commands

Use the commands from the Logger menu to connect to a logger or data
control a remote logger. The Logger menu offers the following comma

P k Plays back data from a logger.

Control Pansi Sets, configures and plays back data from a logger.
Address Book Stores details of loggers and groups of loggers for play
Scheduled Events Stores details of scheduled events.
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The Menu Bar

The menu bar lies directly below the title bar and contains a list ¢
options which will perform particular functions.

To display the contents of a menu _
P Place phger over a menu heading and click the left mouse button. ¢

» Hold down the Alt key and press key that corresponds with the unde
you want.

To choose a menu option
P Click on the option. Or, ,
» Press the letter on the keyboard that corresponds with the underli
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The Toolbar

The toolbar is displayed across the top of the application window, |
provides quick mouse access to many tools used in Pronto. To hide
'Toolbar’ from the ‘View’ menu.

Click on any of the buttons below for a more detailed explanation o

Click To

RR b e e e el A ) ) 6 0 ) P 1) 6 ) 5 ) e B S

Open a new document.

Open an existing document.

Save the active document or template.

Print the active document.

Remove selected data from the document and store it in the cl:
Copy the selection to the clipboard.

Insert the contents of the clipboard at the insertion point.
Plays back data from a logger

Selection cursor. Selects an item whén you click on it.
Inserts text.

Inserts a text box.

Draws an arrow.

Uses the Graph Assistant to add a new graph to a view.
Selects an area of a graph to zoom in on.

Selects an area of a graph to zoom out of.

Pans to the area before the current graphed data.

Pans left.

Pans right.

Pans to the area after the current graphed data.

Inserts trace statistics on the graph.

Uses the Harmonic Analysis Assistant to produce a chart displ:
waveform.

Opens Pronto Help at the contents page.

Allows you to get help on an area of the screen by clicking o
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The Status Bar

------------------------------------------
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The status bar is displayed at the bottom of the Pronto window. To
"Status Bar’ command in the ‘View’ menu.

The left area of the status bar describes actions of menu items as 3
through menus. This area similarly shows messages that describe the
depress them, before releasing them. If after viewing the descriptij

wish not to execute the command, then release tdigemass e fifuthen twhibe
button.

The right areas of the status bar indicate the status of Pronto conc
next scheduled event:

Indicator Description

Offline, efhis box shows whether Pronto is not connected to a logger
logger (’Online’) or connecting to a logger ('Connecting’)

None, etc.This box shows what the status of the next scheduled event
box, the event is ‘On Hold’. If you were in a dialog whil
when you exit the dialog, the event will be 'Pending’, unt
when it will occur. If the event is due to occur on the ¢
and minutes until its start time are shown; if it is due t

date will be shown in the box. If there are no scheduled
'None’.



Arranging Windows and Icons

When you have more than one project and/or view open at a time, each
document window. You may arrange these windows using the options in

To arrange Windows
» Select one of the following options from the ‘Window’ menu:

Cascadewindows are arranged in an overlapping fashion from the top 1
The current window is placed on top of the others.

Tile windows are arranged, filling the screen, without overlapping
above the others.

If you have more than one project qmnwiewanpehhgbuymaydo not wish to
minimized project will be reduced to an icon which you may click on
have several minimized windows, you may use the ‘Window’ menu to arr
bottom of the screen.

To arrange Icons
» From the ‘Windows’ menu, choose 'Arrange Icons’

NB. When you minimize a window, the icons will not be visible if th
tiled. To view the icons, resize the remaining windows so that they
Pronto screen.



What is a Project?

A project is a file which groups collected data together. Data which
transferred to the computer and stored in a project, just as a docum
When you have collected the information in a project you may view di
anomalies, and present the information in a report which can contain

A project can be as large or as small as you like. For example, you
store all data collected on the humidity of a room over a day, a mon

Projects provide a convenient way to organize data, but although dat
does not mean that data from different projects cannot be compared.
project to another, and put data from different projects onto the sa

The information stored in a project is divided into four categories:

Data Streamsta recorded on one channel of the logger. When recordin
played back, they are added on to the existing data stream

Sessions Data recorded over one recording session. A session conta
channels of the logger. Data streams and sessions are ess
viewed in different ways.

ExceptionsException filters describe criteria upon which an exceptio
to scan data for anomalies.

Reports Tables that are created by the user to display the results
display the same data as graphs, but can be examined in de

See Also

The Proiect Brow fiewin ntents of & Proj
What is.a View?




The Project Browser (Viewing the Contents of a Project)

The project browser is the window that appears when a project is ope
project and allows you to select data and graph it. The information
categories, listed in the ‘Category’ box on the left of the window.
contents within each category are displayed.

You can select one or more sessions, data streams, exceptions or rep
the <Ctrl> key and click on each item to select, or hold down the <S§
last item to select ~ all items between these will also be selected.

Category Contents

New Button
Creates a new exception filter or report.
Graph Button
Opens a new view and graphs the selected data stream, session or e
Open Button
Opens the report that i1s selected in the contents section of the p
Properties Button
Opens one of the properties dialog boxes. These display, and allo
selected item from a category.
Delete Button
Permanently removes a selected item from a category.
Preview Button
Views the details of an exception filter and the resulting list of

D ream Data from one channel of a logger; each new session adds
Sessions Data collected from a logger over a particular recording
Exception Fiters A means to separate interesting anomalies from a data st
Reports Tables that are used to display the results collected by

See Also

Sarting a Project
The Data Siream Properties dialog box
Tha Session Propertics dialog box

The Exception Filter Properties diatog box
w Exception Fi

Praviewing the Exception Filter



Sorting a Project
If you wish to rearrange the way in which sessions, data streams, e

may sort them. For example, you may choose to sort the data streams
the sessions by the start date and time.

To Sort a Project

1.0pen the project and select the category to sort.

2.From the ’'Project’ menu choose ‘Sort’.

3.In the ‘Sort Project Data by’ dialog box, click on the name you wi

For Help on the ’Sort Project Data by’ dialog box, click on the ’Hel
using the dialog.
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Opening a Project
When you play back data from the Logger, Pronto will prompt you to ¢
the data. The project will then be opened. You may also open a pr¢

To Open a Project after Playback

l.In the ’Select Project for Playback’ dialog box, select a project
2.If the Project you require is not listed, click the ‘Browse’ buttc
3.In the ‘Browse’ dialog box, deuddeigdddin dihethdirectories’ box to

the directories on your computer .© Type the filename in the ’File
you want.

4.Click the OK button

Opening a Project from the File menu

l1.From the 'File’ menu and select ’'Open’.

2.In the ‘File Open’ dialog box type a name in the ’'File Name’ box c
double-click on the directory icons in the ’'Directories’ window tc

3.Click the OK button

» The four most recently used files are listed at the bottom of the
the list will automatically open the file.

For Help on the 'File Open’ dialog box, click on the ‘Help’ button ¢
dialog.

Shortcuts

Toolbar

Keys: Ctrl + 0
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Creating a Project

When you play back data from the Logger, Pronto will prompt you to ¢
the data. You may choose to add the data to an existing project or
can also create a project from the ’File’ menu in the main Pronto wi

To create a Project after playback

1.Click the ’'New’ butben refledthe Playback Datg dialog box. The 'New Proj
box will appear.

2.Type a name in the ’'File Name’ box. The filename must be no more
extension, e.g. projectl.pdb.

3.You may change directory in which the project wiljedhe ket inddahlele
‘Directories’ box to move through the directories on your computer

4.Click the OK button.

Creating a Project from the File menu .

1.0pen the 'File’ menu and select 'New’.

2.In the 'New’ dialog box select the type of file you wish to create
OK button. The 'New Project’ dialog box will be displayed.

3.In the dialog box type a name in the ‘File Name’ box. The filenan
with a .PDB extension, e.g. PROJECT.PDB, or ROOMTEMP.PDB. Double-
in the ’'Directories’ window to place the project in a different di

4.Click the OK button.

5.The ’'Summary Info’ dialog box will be displayed, allowing you to f
information on the project. It is not necessary to fill in the 'S
button to exit the dialog.

For Help on the ’'New’, 'New Project’ and ’'Summary Info’ dialog boxes
the F1 key whilst using the dialogs.

Shortcuts

Mouse:

Keys: Ctrl + N
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How to Work with Data Loggers

Users increasingly have more than one logger, and these loggers may
directly through different comm ports, or with different phone numbe
Pronto for Windows has an Address Book in which you can store inform
name, network address, and phone number. If you have a set of logge
for scheduled playback for example, thegoyeu Cani puthe eddrnies s Book ¢
control them all via this group as a single item.

It is possible that you will never need more than one entry in the a
only one entry. In this case you may avoid choosing a logger from t
connect, by specifying a default logger to connect to.

Pronto also gives you the opportunity to communicate with your logge
logger options and even configure the legger.

Connecting to the logger
Connaoting fo the Logger
Setting up the modem
Configuring Loggers
Logger Configurations and How They Work
Creating a new Configuration
Gin nfiguration Fil
Saving a Cenfiguration ina File
Reading and Wiiting Configurations
Editirg ntiquration
Printin nfiquration
Organizing loggers
Craaling an Addrass Book
Adding a Logger 1o the Address Book
#in £in 1888
Adding.a Group of Loggers to the Address Book
Editing a Group of Logger in the Address Book

Delgﬁn? 3 Logger or Group from the Address Book
Controlling loggers

Controfting the Logger

Regording
Erasing the loager memory and o ack
Moving ¢ ifferang § r network

Setling the logger clock
Enabling the logger keys

8 g:hgggsﬁng events on a l;ﬁg&g
Playing back data from a logger

Playing back Data from.a Logger
Scheduled Flayback from a Logger
Setting up logger options
ifying a Default L r
S1arting and stopping recording automatically
Erasing logger memory avtomatically
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Connecting to the Logger

A Logger may be connected to a computer either remotely, via ggmmpdem
ports or locally, by a cable plugged directly into the comm port.

If the Logger is connected via a modem you must ensure that the remo
configured correctly, so that data can be transferred between them.
address book you must specify the phone number.

If the connection is a local one, py@iraghenddcepmcpbyttithen yvou add t
to the address book.

To connect the Logger

1.If the logger is a local one, connect the lead to one of the comm 1
sure that the modem is connected to cne of the comm ports.

2.From the 'Logger’ menu choose ‘Playback’ if you want to play back ¢
Panel’ if you want to change logger settings and/or play back data.
entered in the address book, the ’‘Select Instrument for Playback’ «
possible loggers which have had phone numbers, comm ports and baud

3.5elect a logger from the list by clipkins to moverthsénghthbe list.

4.1f the address of the logger is not already in the address book, t
and press the Return key. The ‘Add a New Logger Address’ dialog b«
enter new details. Select the comm port to which you connected yotu
phone number.

5.Choose the 'Edit’ button to change details (such as phone number o

6.Choose the 'Connect’ button to connect to the logger.

See Also
Adding a Logger in the Addrass Book
Editingals rin ine Address Book

a Group of | r the A
cditing a Group.of Logger in the Address Book
Deleting a Logger.or Groun from the Addrass Book
Setting up the modam
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Logger Configurations and How They Work

Logger Confiqurations can be organized and manipulated from two dir
from the menus at the top of the Pronto window. Both directions ha-
control panel is used to read and write configurations to and from
computer; you can also directly edit the configuration of the curre)

18 more geared towards managing the configuration files as separate
prepare configurations independently of the loggers that you have.

Configuring through the Control Panel
The configuration options under the ‘Commands>>‘ button in the conti
Configure Logger... - Opens the Logger Confiquration tab-dialog i
configuration, and alsc save it to a file, export it as a te:
connected logger.
Read Configuration... - Extracts the configuration from the currej
a file. To edit this file, you will have to open it from the
below.

Write Configuration... - Loads the configuration from a selected 1
connected.

Configuring from the menus along the top of the Pronto window

When using the menus, the configuration will always be shown in a o«
very similar to the other windows in Pronto (such as a view), in the
opened, printed, etc. The important menu commands are:

New (File menu) - Allows you to create a new configuration. You 1
for which the configuration will be used. Pronto will then c
which it displays in a new configuration window. This confic
logger; to set other options you will have to edit it by cli
the ’Edit’ menu.

Open (File menu) - Opens a previously created or extracted confiqt

Save/Save As (File menu) - Saves the configuration into a file. 1
logger using the control panel. :

Edit Configuration... (Edit menu) - Opens the Logger Confiquratio:
the configuration, and also save it to a file, export it as ¢

Editing the configuration using the Logger Configuration tab-~dialog
The options and settings for configurations are contained within set
make up E@E&Y?mmgﬁﬁ@ﬁﬁa&QEMQ- You will always use the logger confic

edit configurations, but also within it you have the option to save,
you are editing.

See Also:

Creating a new Configuration
Reading and Writing Configurations
Editing Configurations

Printing s Configuration



What is a View?

A view is a page in which you may place graphs, text and other objects, such as pictures and tables
made in other applications. Each view has its own window.

You can use views in two ways:
» To view and analyze data in graph form.
» To design and print out a report using graphs, pictures and text.

Views are created automatically whenever you choose to graph a session or data stream in a project,
You may also create empty views and design a graph or piece of text to place in that view. You may
move, copy and resize the objects in a view, as well as removing items and adding new ones.

Graphl | Ny B3y oo
, Data Report
3201 !anem;;%y ol This graph shows the fluctuation in
300

. steadily over the tima period. The
initial shamp increase (anomaly a)

i
1
{
i' temperature over five hours. Asis
3 ; : shown, the temparature rose
1
1
1, '

;. ' was dus to user error. :

Temperature (°C}
n
s
o

260 a- R PR | H
; Lot |
2404w e e n e i
%mwmﬁnf * :
24108/54 24:13:00 24108784 !
10:48:10 Time {dd:hhimm} 15:59:01 :
I
. —* on Ch 1 :
n |
i ) o ) -: b

T

§ : i

! texl honeg

grach

CLE muarted abgoct
See Also
Creating a View



Selecting Objects within a View

Before you can move, copy or change a graph, text box or other object in a view you must select it.
Many menu options, such as 'Cuf, and 'Copy" are unavailable until an item has been selected. When
an object is selected, handles appear around it.

To select an object
P Click on the object with the mouse.

Once one object in a view is selected, you may use the Tab key on the keyboard to move through the
other objects in the view.
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Exception Filters - An Introduction

An Exception Filter is a set of parameters that is tested against d
data. The exception filter is a two part process: initially it che:
and/or lower thresholds may be set) and creates a list of all the e:
breached (the ‘exceptions’); this list may then be used to filter t]
data with applicable time periods) to graph only the periods with
The exception filters are shown in the project browser. The list o
viewed on screen, under ‘preview’, from the project browser.
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Graphing the exceptions

To graph the exception filter, you have to go through the graph assi
procedure considerably if you have an exception filter selected befo

To graph the exceptions in an exception filter

l.Select 'Exception Filter’ from the category section of the project

2.Select an exception filter from the contents box.

3.Click on ’Graph’ and then click on 'Finish’ in step 1 of the graph
created with the graph of the first exception. To flick through e
"Zoom Previous’ commands

NB. If you would like your exceptions illustrated by anything other
can change the settings in the graph assistant.

See also:
Panning



Graphing the exceptions

To graph the exception filter, you have to go through the graph assi
procedure considerably if you have an exception filter selected befo

Tc graph the exceptions in an exception filter

l.Select ‘Exception Filter’ from the category section of the project
2.Select an exception filter from the contents box.

3.Click on ‘Graph’ and then click on ’Finish’ in step 1 of the graph

created with the graph of the first exception. To flick through e
rZoom Previous’ commands

NB. If you would like your exceptions illustrated by anything other
can change the settings in the graph assistant.

See also:
Panning



Filtering Other Data with Exception Filter

When exceptions are found in some data on a channel, it is often use
behaving at these times. In Pronto it is possible to filter data fr
exception times from another piece of data, on a different channel.

To filter other data with exception times

1.From the project browser, select the exception filter whose times

2.Click the ‘Graph’ button on the browser.

3.The ’'Graph Assistant Stepl’ dialog box will be displayed. Choose
and then click on 'Finnish’.

See Also
Graph Assistant - 1 diglc 3%
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Properties Dialog Box

The ‘Exception Filter Properties’ dialog box allows you to view and
exception filter. The dialeog box also displays properties which can

You may change the following properties:

Name

Type a new name for the exception filter if you wish. This name v
Description

Type any descriptive text here. This text is for your reference ¢

Print Preview
Choose this button to go to the ‘Previewing the Exception Filter‘
exception filter and details of the exceedences.
Print...
Choose this button to go to the 'Print’ dialog box, where you can
and details of the exceedences, as are shown in the preview.
OK
Choose this button to save the changes and exit the dialog box.
Cancel
Choose this button to close the dialog box without saving the cha:

See also:

The Preview Dialog Box
The Print diglog box




